通达信黄金量柱指标公式@财富池

[复制链接]
查看332 | 回复2 | 2021-8-20 04:12:40 | 显示全部楼层 |阅读模式

以下是通达信黄金量柱指标公式@财富池(无源码的请下载附件导入)

现在的指标满目淋漓,想找到一个如意的真不容易
 现在找到感觉还真不错的通达信指标
 喜欢的朋友可以拿去用


 

绿低量:=10;

蓝低量:=50;

灰低量:=100;

 H_L:=0.1*CONST(HHV(VOL,240));

 {MAV10:MA(V,10),COLORYELLOW;}

异动135:MA(V,135),COLORMAGENTA;

洗盘40:MA(V,40),COLORBLUE;

启动5:MA(V,5),COLORWHITE;

 VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);{模拟量}

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,1,-1),COLOR00C0C0;

量:VOL,VOLSTICK,COLORLIGRAY;

换手: VOL*10000/FINANCE(7),NODRAW,COLORGREEN; {DYNAINFO(37)*100}

全换手周期: SUMBARS(V,CAPITAL),NODRAW,COLORLIGREEN;{求完全换手到现在的周期数}

量比: V/REF(MA(V,5),1),COLORBROWN,NODRAW;

几倍: V/REF(V,1),COLORYELLOW,NODRAW;

倍数:=1.9;

倍量: VOL>=REF(V,1)*倍数 AND (IF(C<O,C>REF(C,1),1)),COLORYELLOW,NODRAW;

倍缩: REF(V,1)>=VOL*倍数,COLORMAGENTA,NODRAW;

平量: RANGE(V/REF(V,1),0.97,1.03) AND BARSCOUNT(V)>=2,COLORWHITE,NODRAW;

低量10: VOL=LLV(VOL,绿低量) AND BARSCOUNT(V)>=绿低量,COLORGREEN,NODRAW;

低量50: VOL=LLV(VOL,蓝低量) AND BARSCOUNT(V)>=蓝低量,COLORBLUE,NODRAW;

地量: VOL=LLV(VOL,灰低量) AND BARSCOUNT(V)>=灰低量,COLORGRAY,NODRAW;

 V1:=VOL*0.95;{图标位置}

V2:=VOL*0.85;

 STICKLINE(倍量, 0,V1,1,0),COLORYELLOW;

 STICKLINE(平量,0,V1,1,0),COLORWHITE;

 STICKLINE(低量10,0,V2,1,0),COLORBLACK;

 STICKLINE(低量50,0,V2,1,0),COLORBLUE;

 STICKLINE(地量,0,V2,1,0),COLORGRAY;

 STICKLINE(倍缩,0,V*0.45,1,0),COLORMAGENTA;

 STICKLINE(C<O AND C>REF(C,1),0,V1,0,0),COLORRED;{假阴柱}

 

真阳或假阴:=C>O OR C>REF(C,1);

收阳:= REF(真阳或假阴,3);

倍量1:=REF(倍量,3);

高量:=REF(V,3)>=HHV(V,7){原为HHV(V,7)};

三日不破:= LLV(C,3)>=REF(L,3);

 {价升:=COUNT(C>=REF(C,1),3)=3;}{收盘价逐升原指标}

价升:=LLV(C,3)>REF(L,3);

 {量缩:=COUNT(V<=REF(V,1),3)=3;}{原指标}

量缩:=HHV(V,4)=REF(V,3);

连阳:= COUNT(真阳或假阴,3)=3;

阳线:=REF(C,3)>REF(O,3);

倍量将军柱:= 倍量1 AND 三日不破 AND 收阳;

高量将军柱:= 高量 AND 三日不破 AND 收阳;

将军柱:= 倍量将军柱 OR 高量将军柱;

黄金柱:= 将军柱 AND 价升 AND 量缩 AND 阳线 ;{标准黄金柱}
 

STICKLINE(黄金柱,0.3*V,0.7*V,1,0),COLORRED; {红柱}

DRAWICON(黄金柱,V*1.5,1);

 V100:= V<=LLV(V,100)*1.2 AND V>0 AND BARSCOUNT(V)>=100;

百日地量群:=COUNT(V100,5)>=3;

 DRAWTEXT(FILTER(百日地量群,4),V+3*H_L,'地量群'),COLORGRAY;

长阴短柱:=C/REF(C,1)<=0.96 AND V<HHV(V,30)/1.9;

 DRAWTEXT(长阴短柱 ,V+1.6*H_L,'!'),COLORLICYAN;
 

725400615.png

725400615.png

725499995.png

725499995.png

回复

使用道具 举报

bideliu | 2022-1-19 22:32:04 | 显示全部楼层
黄金量柱副图公式,倍量、缩量、平量、梯量、地量等一目了然
回复

使用道具 举报

bideliu | 2022-1-19 22:33:54 | 显示全部楼层
黄金量柱副图公式,倍量、缩量、平量、梯量、地量等一目了然
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则